|SAKAKI(7)||Miscellaneous Information Manual||SAKAKI(7)|
sakakibox is a PC Engines apu1 with 2 gigabytes of RAM and 3 Realtek gigabit Ethernet interfaces.
It runs Coreboot with SeaBIOS and NetBSD. The coreboot build is:
Build 9/8/2014 (beta, reduced spew level)
This was flashed due to issues with miniPCIe with earlier builds.
Currently it boots from a SD card, and the mSATA SSD slot is now unpopulated - we are unsure if the drive was bad or the controller was bad. There are two miniPCIe slots, which could be filled with pci(4) cards for ieee80211(4) or LTE, but are currently unpopulated. There is also "SATA proper", which is unpopulated because we don't have a big enough case to fit a drive. There is GPIO, but we need a newer OS release for that.
The case is dented due to a fat cat sleeping on it. You can infer from this that the hardware gets warm - it does, about 60C idle. Do not unscrew the motherboard, you will need to reapply some fragile heat pads.
sakakiis currently performing the following functions:
Services are configured by editing /etc/rc.conf, see rc.conf(5). They are started/stopped/restarted with the service(8) command . A static shell script /etc/rc.local can also contain local services, but we should avoid this and use real rc.subr(8) init scripts where we're able. As well as cron(8), you can add entries to the scripts /etc/daily.local (etc.) to run periodic tasks. The admin writing this text prefers this to cron(8) in most situations.
Kernel settings are changed with sysctl(8), and read on boot from /etc/sysctl.conf, see sysctl.conf(5). The main ones we change are the ones that enable packet forwarding and raise the secmodel_securelevel(9).
Many configuration examples for core OS things (including the firewall) can be found in /usr/share/examples.
If you would like to learn how to use BSD vi(1), try:
For system monitoring, to be a pro extreme super BSD user, try
top(1) is often more accurate than htop on
NetBSD, and less disappointing than the versions of
top common on Linux. Many network stack statistics can also be learned from
sysctl -a | less’.
In case of emergency, ktrace(1) is the typical system call trace utility. strace is also available from packages, but is less useful.
By default, pkgsrc installs software to /usr/pkg. If you're more familar with Linux, this is like /usr, but only for third-party software. If you're more familiar with (Free|Open)BSD, this is like /usr/local. On NetBSD, /usr/local is for anything that is not part of the core OS, and has not been installed from the packaging system.
Configuration for third-party software is contained in /usr/pkg/etc. The packaging system cannot touch this directory except to install example files from /usr/pkg/share/examples.
You can check if there are any vulnerable packages with:
List the contents of a package:
pkg_info -L chrony
Identify a mysterious file:
pkg_info -F /usr/pkg/bin/msgfmt
The root account should also recieve email about vulnerable packages. NetBSD uses mail(1) as a notification system.
service npf reload’.
Please note that using the following NetBSD bootloader option is essential to get serial output in the installer image:
You can update the packages using pkgin(1). You may need to change /usr/pkg/etc/pkgin/repositories.conf to point at a newer repository occasionally.
New coreboot firmware can be flashed with flashrom(8), available in pkgsrc. Please be very careful when doing this.
man ./sakaki.7’. Verify it is correct with ‘
mandoc -T lint ./sakaki.7’.
|March 29, 2021||NetBSD 9.99.81|